Summary
This article provides troubleshooting steps to resolve the "Flight returned unavailable" error when attempting to establish an Arrow Flight ODBC connection from Windows/Linux clients to an SSL-enabled Dremio instance.
Reported Issue
When trying to make an Arrow Flight ODBC connection from Windows/Linux based client machines to an SSL-enabled Dremio instance, users may encounter a "Flight returned unavailable" error with the message "failed to connect to all addresses." This error can be challenging to diagnose and may be caused by SSL setup issues on the Dremio side, SSL environment issues, or other factors.
Relevant Versions
All versions of Dremio.
Troubleshooting Steps
1. Download the "openssl-1.0.2j-fips-x86_64" package.
2. Create an OpenSSL folder in C:\.
3. Copy openssl-1.0.2j-fips-x86_64\OpenSSL\bin\openssl.cnf to C:\OpenSSL.
4) CD in to \OpenSSL\bin and run 'openssl.exe version
' to verify the version e.
openssl.exe version
OpenSSL 1.0.2j-fips 26 Sep 2016
5. Run the following openssl commands against the relevant JDBC (31010) or Arrow flight ODBC (32010) port:openssl s_client -connect <dremio hostname>:32010
openssl s_client -showcerts -connect <dremio hostname>:32010
Cause
The "Flight returned unavailable" error can occur due to various reasons, including SSL setup issues on the Dremio side, SSL environment issues, or other factors that prevent a successful connection from Windows/Linux clients to the SSL-enabled Dremio instance.
Steps to Resolve
Follow the troubleshooting steps outlined above to diagnose and resolve the issue.
Additional Resources
https://docs.dremio.com/current/sonar/client-applications/clients/microsoft-power-bi/troubleshooting-connectivity/
https://docs.dremio.com/cloud/sonar/client-apps/drivers/arrow-flight-sql-jdbc/#adding-the-root-ca-certificate-to-your-system-truststore
https://docs.dremio.com/current/get-started/cluster-deployments/customizing-configuration/dremio-conf/wire-encryption-config/