Summary
This article describes an issue where Dremio Cloud cannot access S3 buckets or Dremio Sample Sources, typically due to a misconfigured subnet.
Reported Issue
Errors can occur when navigating to S3 bucket folders or Dremio Sample Sources, indicating that Dremio Cloud cannot access the S3 bucket.
Relevant Versions
Dremio Cloud
Troubleshooting Steps
Check that you can query the sample sources or a table from a S3 source.
Cause
This issue is typically due to the engines not having internet connectivity to S3. Testing the sample sources is a quick way to indicate this, as it is an S3 source connection.
Steps to Resolve
Check that you have met all the prerequisites for connectivity: https://docs.dremio.com/cloud/signing-up/prerequisites-and-permissions/#prerequisites
Common Issues:
- If using public subnets, having "Auto Assign IPv4 IP Addresses" enabled on the subnets
- If using private subnets, having a NAT gateway set up