Issue
After upgrading Dremio from v25.0.3 to v25.1.5, none of the data sources are visible or accessible to the users from the UI. Where the data sources are normally listed an error is shown similar to this:
<ARP_Source> source type is not installed. Please download it from Dremio Hub: https://github.com/dremio-hub.
Troubleshooting Steps
- Check the coordinator's server.log and see if following error messages are found. In this example, the missing jar file is for an HBase source:
2024-12-10 04:33:14,453 [main] ERROR c.dremio.exec.catalog.PluginsManager - Failed to update legacy format for the source [HBase Prod]. Reason: HBase source type is not installed. Please download it from Dremio Hub: https://github.com/dremio-hub..
com.dremio.exec.exception.MissingSourceTypeException: HBase source type is not installed. Please download it from Dremio Hub: https://github.com/dremio-hub.
at com.dremio.exec.catalog.ConnectionReaderImpl.getConnectionConf(ConnectionReaderImpl.java:123)
at com.dremio.exec.catalog.ConnectionReaderDecorator.getConnectionConf(ConnectionReaderDecorator.java:58)
at com.dremio.service.namespace.AbstractSourceConfig.getConnectionConf(AbstractSourceConfig.java:68)
at com.dremio.exec.catalog.PluginsManager.migrateLegacySourceFormat(PluginsManager.java:334)
at com.dremio.exec.catalog.PluginsManager.start(PluginsManager.java:376)
at com.dremio.exec.catalog.CatalogServiceImpl.start(CatalogServiceImpl.java:243)
at com.dremio.service.SingletonRegistry$AbstractServiceReference.start(SingletonRegistry.java:166)
at com.dremio.service.ServiceRegistry.start(ServiceRegistry.java:90)
at com.dremio.service.SingletonRegistry.start(SingletonRegistry.java:47)
at com.dremio.dac.daemon.DACDaemon.startServices(DACDaemon.java:214)
at com.dremio.dac.daemon.DACDaemon.init(DACDaemon.java:220)
at com.dremio.dac.daemon.DremioDaemon.main(DremioDaemon.java:102)
2024-12-10 04:33:15,777 [main] ERROR o.a.hadoop.hive.common.FileUtils - The jar file path /etc/hbase/conf.cloudera.hbase/hbase-site.xml doesn't exist
- Check and confirm if all the queries are running fine
- Users are not able to view or access data sources from the UI
Root Cause
This is a known issue (DX-95038): if an jar file for and ARP-based source is missing from the jars/3rdparty directory when starting v25.1.x, the source is marked as unavailable in the server.log (as expected) and the UI presents the user with the above error. At this point the user has no access to any additional sources they may have configured. This issue could occur due to any source connector developed with ARP framework if the jar file is missing. In the above example, it's an HBase source connector.
Resolution
To resolve the issue, place the expected jar file into the jars/3rdparty directory and restart Dremio.