Summary
This article discusses how to resolve a manifest unknown or connection refused error when trying to pull / download the latest dremio-enterprise v26 images from the Quay.io repository,
Reported Issue
When attempting to pull the dremio images from Quay.io via a docker pull
, the following errors may be seen: dremio/dremio-enterprise:26.0.0 not found manifest unknown: manifest unknown
or connect: connection refused
from podman pull
.
Relevant Versions
This issue applies to Dremio versions 26.x and onwards.
Troubleshooting Steps
1. Confirm that Dremio Support have provided Dremio repository access to the Quay.io docker repo images against the quay.io id provided.
2. Check to see if any other non Dremio images pull / download without issue e.g mongo db operator: docker pull quay.io/dremio/dremio-mongodb-operator:1.19.1-dremio-20250319163742-5670cbfe
.
2. Confirm if the following errors are observed when trying to pull the dremio-enterprise image (Not to be confused with dremio-ee as the images under this directory are pre v26 images): dremio/dremio-enterprise:26.0.0 not found manifest unknown: manifest unknown
or connect: connection refused
from podman pull
.
3. Carry out the "Steps to Resolve" described below.
Cause
This is likely to be the case where not all Quay.io endpoints are whitelisted/allowed in the firewall on the customer side.
Steps to Resolve
Review the advise from Red Hat documentation here https://access.redhat.com/articles/7084334 on Firewall changes for container image pulls 2024/2025 and apply the appropriate changes to implement allow lists within the customer side firewall systems to include all the Quay.io endpoints.
Additional Resources
Obtaining Access to Download from Quay.io: https://support.dremio.com/hc/en-us/articles/29108242100891-Obtaining-access-to-docker-repo-images-hosted-in-quay-io
Firewall changes for Quay.io endpoints: https://access.redhat.com/articles/7084334