Overview
Queries are not executing and you see the error message "Scaling up the engine replicas failed, please check the engine scaling events page for more details"
Applies To
Dremio Cloud
Details
Different errors can occur if the VPC used for Dremio Cloud is not configured correctly. Viewing the error in the engine events will help you narrow down the issue. Some error examples:
Scaling Failed. com.dremio.daas.ems.common.CloudNonRetriableException:
software.amazon.awssdk.services.ec2.model.Ec2Exception: The subnet ID ‘subnet-…’ does
not exist (Service: Ec2, Status Code: 400, Request ID: …, Extended Request ID: null)
Scaling Failed. com.dremio.daas.ems.common.CloudNonRetriableException:
software.amazon.awssdk.services.ec2.model.Ec2Exception: The Vpc Endpoint Id 'vpce-.....'
does not exist (Service: Ec2, Status Code: 400, Request ID: ........,
Extended Request ID: null)
Scaling Failed. com.dremio.daas.ems.common.CloudNonRetriableException:
software.amazon.awssdk.services.ec2.model.Ec2Exception: The security group 'sg-.....'
does not exist in VPC 'vpc-...........' (Service: Ec2, Status Code: 400,
Request ID: ........, Extended Request ID: null
Cause
An incorrectly associated security group, subnet, vpce, or incorrectly configured VPC will cause the engines to fail to scale up. This will result in queries failing, even on the sample sources.
How to Check the Engine Scaling Events Page
1. In the Dremio Cloud UI, click on the Gear cog on the left hand side and select Project Settings
2. Select Engines
3. Select the engine that is showing stopped/idle (the default engine is preview)
4. Select the Events tab
5. Under descriptions on the right hand side, hover over the "Scaling failed..." text, and it will show a pop up with the full error message.